ITPUB论坛-中国专业的IT技术社区

 找回密码
 注册
查看: 845|回复: 5

安zabbix时如何知道安装哪些包

[复制链接]
论坛徽章:
32
优秀写手
日期:2014-07-23 06:00:13技术图书徽章
日期:2016-08-05 10:29:11秀才
日期:2016-08-05 10:33:40秀才
日期:2016-08-05 10:34:04秀才
日期:2016-08-05 10:34:04技术图书徽章
日期:2016-08-05 10:34:13秀才
日期:2016-08-05 10:38:01秀才
日期:2016-08-05 10:38:26秀才
日期:2016-08-05 10:38:26技术图书徽章
日期:2016-08-05 10:38:34
跳转到指定楼层
1#
发表于 2017-8-31 10:38 | 只看该作者 回帖奖励 |倒序浏览 |阅读模式
本帖最后由 flzhang 于 2017-8-31 11:21 编辑

敢问如果安装linux的软件比如zabbix,之前需要安装很多包,即便用yum配置,又如何快速知道
安装哪些包呢?
另外,安装zabbix的版本不同需要安装的包的版本也不同,那么如何知道相关组件都安什么对应版本的包呢?
有没有类似个网站说明安装对应软件就按什么包的?
比如 yum install mysql-dev gcc net-snmp-devel curl-devel perl-DBI php-gd php-mysql php-bcmath php-mbstring php-xm
如果刚出来的软件网上没资料,只是自己看文档,有什么通用方法知道yum后面要安装这么多包啊

认证徽章
论坛徽章:
12
优秀写手
日期:2014-09-03 06:00:13双鱼座
日期:2015-12-16 10:37:41天蝎座
日期:2015-12-02 14:44:59秀才
日期:2015-11-11 09:58:34ITPUB14周年纪念章
日期:2015-10-26 17:23:44巨蟹座
日期:2015-09-02 14:45:30金牛座
日期:2015-08-25 16:02:53天蝎座
日期:2015-07-21 16:49:04喜羊羊
日期:2015-07-07 16:42:312015年新春福章
日期:2015-03-06 11:59:47
2#
发表于 2017-8-31 10:50 | 只看该作者
安装任何软件程序的时候都会提示依赖的啊,依赖哪些装哪些好了

使用道具 举报

回复
论坛徽章:
32
优秀写手
日期:2014-07-23 06:00:13技术图书徽章
日期:2016-08-05 10:29:11秀才
日期:2016-08-05 10:33:40秀才
日期:2016-08-05 10:34:04秀才
日期:2016-08-05 10:34:04技术图书徽章
日期:2016-08-05 10:34:13秀才
日期:2016-08-05 10:38:01秀才
日期:2016-08-05 10:38:26秀才
日期:2016-08-05 10:38:26技术图书徽章
日期:2016-08-05 10:38:34
3#
 楼主| 发表于 2017-8-31 11:19 | 只看该作者
本帖最后由 flzhang 于 2017-8-31 11:21 编辑
fuiou_cary 发表于 2017-8-31 10:50
安装任何软件程序的时候都会提示依赖的啊,依赖哪些装哪些好了

开始怎么知道安哪些包呢,就像
比如 yum install mysql-dev gcc net-snmp-devel curl-devel perl-DBI php-gd php-mysql php-bcmath php-mbstring php-xm
如果刚出来的软件网上没资料,只是自己看文档,有什么通用方法知道yum后面要安装这么多包啊。不可能一个一个试吧

使用道具 举报

回复
认证徽章
论坛徽章:
12
优秀写手
日期:2014-09-03 06:00:13双鱼座
日期:2015-12-16 10:37:41天蝎座
日期:2015-12-02 14:44:59秀才
日期:2015-11-11 09:58:34ITPUB14周年纪念章
日期:2015-10-26 17:23:44巨蟹座
日期:2015-09-02 14:45:30金牛座
日期:2015-08-25 16:02:53天蝎座
日期:2015-07-21 16:49:04喜羊羊
日期:2015-07-07 16:42:312015年新春福章
日期:2015-03-06 11:59:47
4#
发表于 2017-8-31 11:38 | 只看该作者
flzhang 发表于 2017-8-31 11:19
开始怎么知道安哪些包呢,就像
比如 yum install mysql-dev gcc net-snmp-devel curl-devel perl-DBI ph ...

这些都是前人总结过的,最开始的时候肯定都是需要一步步来获取的,没有前人资料的话,要安装什么东西你就直接去装就好了啊,环境缺什么他都会告诉你的,没有捷径可走

使用道具 举报

回复
论坛徽章:
32
优秀写手
日期:2014-07-23 06:00:13技术图书徽章
日期:2016-08-05 10:29:11秀才
日期:2016-08-05 10:33:40秀才
日期:2016-08-05 10:34:04秀才
日期:2016-08-05 10:34:04技术图书徽章
日期:2016-08-05 10:34:13秀才
日期:2016-08-05 10:38:01秀才
日期:2016-08-05 10:38:26秀才
日期:2016-08-05 10:38:26技术图书徽章
日期:2016-08-05 10:38:34
5#
 楼主| 发表于 2017-8-31 16:50 | 只看该作者
fuiou_cary 发表于 2017-8-31 11:38
这些都是前人总结过的,最开始的时候肯定都是需要一步步来获取的,没有前人资料的话,要安装什么东西你就 ...

比如maven安装库一个spring的库,直接到网站上能查到对应需要什么具体的包,yum难道没有这样的网站么

使用道具 举报

回复
论坛徽章:
0
6#
发表于 2017-9-1 06:25 | 只看该作者
zabbix网站有说明文档 再就是yum install 的时候会有依赖包的信息 就可以在安装前看的到了
来自苹果客户端来自客户端

使用道具 举报

回复

您需要登录后才可以回帖 登录 | 注册

本版积分规则

TOP技术积分榜 社区积分榜 徽章 电子杂志 团队 统计 虎吧 老博客 知识索引树 读书频道 积分竞拍 文本模式 帮助
  ITPUB首页 | ITPUB论坛 | 数据库技术 | 企业信息化 | 开发技术 | 微软技术 | 软件工程与项目管理 | IBM技术园地 | 行业纵向讨论 | IT招聘 | IT文档 | IT博客
  ChinaUnix | ChinaUnix博客 | ChinaUnix论坛 | SAP ERP系统
CopyRight 1999-2011 itpub.net All Right Reserved. 北京盛拓优讯信息技术有限公司版权所有 联系我们 网站律师 隐私政策 知识产权声明
京ICP备16024965号 北京市公安局海淀分局网监中心备案编号:11010802021510 广播电视节目制作经营许可证:编号(京)字第1149号
  
快速回复 返回顶部 返回列表
http://www.vxiaotou.com